CRM software runs my life

ReadyNAS Issues

ReadyNAS units mounted in the rack
We recently purchased a Netgear ReadyNAS unit (formerly made by Infrant Technologies). It is a nice compact little unit, 1RU with 4 hard drives across the front. It runs an onboard Debian install with some custom software to support X-RAID, the front panel buttons and a nice web interface.

We have run into some issues lately in relation to the performance of the device over the network. Their general advice is to do a direct connect and check your network drivers, but this hasn’t helped our fault. When logged into the SSH server on the system I can see that the CPU is running at 90%+ pretty consistently during usage. These are smb processes running under the various usernames that have access to the file shares. Even when the desktops are idle they are chewing CPU cycles on the NAS.

After about 24 hours of usage the NAS starts to become unresponsive. In particular the web interface actually crashes the browser (both IE and Firefox). I am trying leaving oplocks turned off at the moment as some people have suggested, but I am not seeing any reduction in CPU usage. Apparently these problems have been fixed in the latest beta, with the next prod version due in ‘a couple of weeks’. It can’t come soon enough as far as I am concerned.

Previous

Ferrari 360 Spider

Next

How to buy a house

1 Comment

  1. Dave

    ReadyNAS 1100 come default in Flex-RAID mode. With v4 firmware, they run much better in X-RAID mode. Requires a factory default to switch it. See #11 on http://www.readynas.com/?p=310#Troubleshoot

Leave a Reply to Dave Cancel reply

Your email address will not be published. Required fields are marked *

Powered by WordPress & Theme by Anders Norén